Author Topic: Rough first range day  (Read 1038 times)

0 Members and 2 Guests are viewing this topic.

Offline Superdave532

  • Newbie
  • *
  • Posts: 17
Rough first range day
« on: September 09, 2017, 04:00:17 PM »
Picked up my Scorpion just a few weeks ago after years of lusting after one, and I was finally able to get to the range today (go **** yourself hurricane Harvey).  Needless to say I was very excited.

Unfortunately, I had several failures to feed.  I was using a mix of Speer lawman 147 grain, as well as my buddy's winchester and american eagle ammo.  About half of the shots were suppressed and half regular.  About 250 of the 400 rounds were the Speer ammo, and that seemed to be where the only issues came from.  Thing is, I probably had at least a dozen jams.  Sometimes, the failed round had a deep shaving off of the side of the case, while in one instance the bullet itself had a massive dent in the side of it after being jammed up against the chamber sideways.

I noticed one other thing that seemed relevant when I finished cleaning the gun:  I had used only my two Manticore metal feed lip mags today, and now when I run the charging handle on them (not sure if it was like that before, but I don't believe it was an issue) neither of them will lock back the bolt when they are empty.  My factory mags still do, but unfortunately I didn't bring any of those to the range to get a performance comparison.  My hunch is that they're not sitting high enough in the pistol to seat the bullet properly for feeding (which would explain the scraping and possibly the weird, sideways jamming angles), but I know these have been very popular so I wanted to see if someone else had a similar issue.

I've had two CZ pistols in the past, including a P01 sitting in the queue at CGW.  This was the first time I've had any sort of failure with any CZ product, so obviously I was very surprised.  Looking forward to any insight you guys might have, and I hope I can get this sorted.

Online jason.luster.50

  • Newbie
  • *
  • Posts: 16
Re: Rough first range day
« Reply #1 on: September 09, 2017, 04:07:49 PM »
I ran my manticore mags for the first time on Monday supressed with 147gr lawmen had a failure to feed half way through each mag on first use and none on second use but that's all the more I shot that day so further testing is needed your results don't make me hopeful

Sent from my Pixel using Tapatalk


Offline akuser47

  • Hero Member
  • *****
  • Posts: 828
Re: Rough first range day
« Reply #2 on: September 09, 2017, 07:36:02 PM »
Do you have any pictures of the malfunction you could share. I mean can you replicate it and get some pictures please do it safely. It might help us to also see clean clear shots of the chamber face as well to see if the chamber was relieved/chamfered enough to aid in feeding. I am not sure what you have going on yet, but plenty here will help if we can.

Offline ndmiller

  • Newbie
  • *
  • Posts: 9
Re: Rough first range day
« Reply #3 on: September 09, 2017, 08:43:03 PM »
Did these malfunctions occur with OEM mags as well?

Offline Thrillbilly

  • Jr. Member
  • **
  • Posts: 81
Re: Rough first range day
« Reply #4 on: September 09, 2017, 09:04:18 PM »
HP, FMJ or TMJ lawman?

Offline SouthernScorp

  • Hero Member
  • *****
  • Posts: 774
Re: Rough first range day
« Reply #5 on: September 10, 2017, 12:48:18 AM »
maybe manticore has a bad batch? I've got about 1000 rnds through each of mine "got them when they first came out" no errors or jams...
CZ Scorpion Evo S1 Pistol:

SLR Synergy Mini comp
SBT-EVO Brace
PMM Safety Levers
Dual HBI Prostock Charging Handles
Gearhead Mag Release
HBI Trigger Spring
HBI Delta Trigger
PMM QD Front & Rear
Magpul MS1 + QDs
Holosun HS515cu on ADM low mount
Vendetta VP-17-A AFG

Offline Superdave532

  • Newbie
  • *
  • Posts: 17
Re: Rough first range day
« Reply #6 on: September 10, 2017, 08:38:59 AM »
Thanks for the responses guys.  In order of post:

I didn't get any picture from the range unfortunately.  I'll bring my camera next time I'm at the range and try to get them on here.

I didn't bring any OEM mags with me, I figured two would be enough for an indoor range.  Really wish I had now, obviously and I will bring them next time.

I'm pretty sure they were TMJ lawman.  Don't have any boxes yet but I'll ask my friend that buys them.

I hope it's just a bad batch of mags and not something wrong with my gun.  I'll put a couple hundred more rounds through it soon, probably american eagle or winchester, and see if the factory mags give me any hiccups.  I think there's pretty clearly something amiss with the Manticore's that I received though.

Offline Asmodeus

  • Sr. Member
  • ****
  • Posts: 378
Re: Rough first range day
« Reply #7 on: September 10, 2017, 06:54:53 PM »
I have plenty of 147gr TMJ through mine without an issue. 

OEM mags. 

Offline Huntour

  • Newbie
  • *
  • Posts: 5
Re: Rough first range day
« Reply #8 on: September 10, 2017, 08:16:30 PM »
I have read about other issues with the Manticore mags.  I was getting ready to pick up two just today but the shipping cost put me off.  I'll pay attention to how this plays out with the OP before getting some.

Offline Thrillbilly

  • Jr. Member
  • **
  • Posts: 81
Re: Rough first range day
« Reply #9 on: September 10, 2017, 08:36:42 PM »
It may be the mags, ammo, or gun. Usually your gut feeling is right about things though.

Do you have a digital caliper?  If so, carefully compare the diameter and length of the ammo with known good ammo. Pay special attention to the rim of the case too.

If that is fine, check the lips on the mags and seating depth when mounted in the frame.  Compare that with a factory mag.

Also run some good ammo through a factory mag and see how that performs.

Take a good look at the feed ramp and bolt too for anything unusual.

That should give you a good idea of whats wrong, if its one thing, or several working together.

Offline krav51

  • Newbie
  • *
  • Posts: 10
Re: Rough first range day
« Reply #10 on: September 11, 2017, 06:02:26 AM »
I had the same experience the first time i shot mine.The feed ramp was very rough and clearly not centered .I sent it back and they opened up and polished the feed ramp.They also "adjusted the bolt" (i have no idea how you adjust a bolt).Been 100% since then with ball and hollow points.

Offline yzjohn

  • Newbie
  • *
  • Posts: 8
Re: Rough first range day
« Reply #11 on: September 11, 2017, 08:02:48 AM »
  manticore arms mags would not feed consistently when my
scorpion was new, never had a problem with 20 and 30 round
CZ mags. after approx. 100 rounds problem went away.

Offline ndmiller

  • Newbie
  • *
  • Posts: 9
Re: Rough first range day
« Reply #12 on: September 11, 2017, 09:51:38 AM »
I didn't bring any OEM mags with me, I figured two would be enough for an indoor range.  Really wish I had now, obviously and I will bring them next time.

Too many variables changed to really diagnose.  Call a mulligan and pretend next range session is the first.  Use OEM mags and reshoot ammo that worked and didn't.

If you don't see failures, return the Manticore mags and just stick with OEM.  They are inexpensive and warrantied essentially forever by CZ should any issues arise.  I have just under 5K rounds on my original 20's that came with the gun and 30's I bought shortly after with no issues on any ammo I have used.  Bought a case of 30's when the pistol first came out and haven't even opened it yet.

If you do see failures, depending on ammo type, may want to send on a trip back to cz for adjustment/fix.

Noah

Offline SouthernScorp

  • Hero Member
  • *****
  • Posts: 774
Re: Rough first range day
« Reply #13 on: September 11, 2017, 06:53:40 PM »
try and snap a pic of your feed ramps, we might be able to see one of those "aha there it is" problems. is it rough or polished nice and smooth ?
CZ Scorpion Evo S1 Pistol:

SLR Synergy Mini comp
SBT-EVO Brace
PMM Safety Levers
Dual HBI Prostock Charging Handles
Gearhead Mag Release
HBI Trigger Spring
HBI Delta Trigger
PMM QD Front & Rear
Magpul MS1 + QDs
Holosun HS515cu on ADM low mount
Vendetta VP-17-A AFG

Offline Superdave532

  • Newbie
  • *
  • Posts: 17
Re: Rough first range day
« Reply #14 on: September 12, 2017, 07:07:22 PM »
Hello everyone.  Thank you so much for taking the time to respond.  Once again, I really appreciate this community :)

I haven't had a chance to get out to the range yet (hopefully I'll be able to this weekend) but I've uploaded some pictures for y'all to look over. 


The first one shows one of the Manticore mags (left) and factory mag (right).  It looks to me like the shape of the metal on the Manticore is the obvious culprit for lock-back failures, as it doesn't go up as high on the sides as the factory mag does, with the result being that the bolt lock/release isn't engaged.  Let me know if I'm wrong on that.  Also note that the little gray piece on the left is a plastic piece that broke off of the Manticore mag from underneath the metal.  I've gotten in touch with prepper gun shop and I'll let you know what they say.


The second and third pics are of the feed ramp from below and from the ejection port.  To me, it looks like it should be alright.  There are no obvious burs or mis-alignments that I can see, but please let me know if you see an issue with this in particular.





Again, thanks so much for your time everyone - like I said before, I'm a huge fan of CZ products so I would love to get this bad boy up and running 100%.  I'm going to try and shoot again this weekend with the factory mags and I'll let y'all know how it goes.