Author Topic: Scored a nice ITM AT84S, but it won't run  (Read 1466 times)

0 Members and 1 Guest are viewing this topic.

Offline jwc007

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 7312
Re: Scored a nice ITM AT84S, but it won't run
« Reply #45 on: February 13, 2018, 01:48:18 PM »
The force used to manually extract a round from the chamber is quite different from the forces encountered when the slide is cycled by rounds fired.  It may be that the extractor spring is just weak. The fix may be as simple as getting a new extractor spring... (I don't remember, but Wolff extra strength extractor springs MIGHT work in the AT-84s.)

Yes, the Wolff Extra Power Extractor Springs WILL work in the Swiss ITM AT84S!  You might wind up trimming a coil, but they will work.
"Easy is the path to wisdom for those not blinded by ego." - Yoda


For all of those killed by a 9mm: "Get up! You are not dead! You were shot with a useless cartridge!"

Offline mikebaker1129

  • Jr. Member
  • **
  • Posts: 81
Re: Scored a nice ITM AT84S, but it won't run
« Reply #46 on: February 25, 2018, 08:35:27 PM »
I had the same problem with a used AT84s I purchased used. Broken ejector, I sourced several Tanfoglio sear cages and sent them along with the pistol to  Brian Ahearn at EFR,he modified one to fit and it functions great now.
I paid $200 for the pistol and I forget what Brian charged,but it was worth it to me!
He is a forum member here, if you want to reach out to him.

Offline Bret

  • Hero Member
  • *****
  • Posts: 1456
Re: Scored a nice ITM AT84S, but it won't run
« Reply #47 on: February 25, 2018, 09:54:11 PM »
Mike, did yours also have the problem of the hammer falling to half cock?

Offline mikebaker1129

  • Jr. Member
  • **
  • Posts: 81
Re: Scored a nice ITM AT84S, but it won't run
« Reply #48 on: March 02, 2018, 09:22:29 PM »
Mike, did yours also have the problem of the hammer falling to half cock?
No, it did not.

 

anything